Excel выбрать несколько значений

Функция ВЫБОР(), английский вариант CHOOSE(), возвращает значение из заданного списка аргументов-значений в соответствии с заданном индексом. Например, формула =ВЫБОР(2;»ОДИН»;»ДВА»;»ТРИ») вернет значение ДВА. Здесь 2 — это значение индекса, а «ОДИН»;»ДВА»;»ТРИ» это первый, второй и третий аргумент соответственно.

Функция ВЫБОР() в Excel достаточно проста: Вы задаете массив значений, и порядковый номер (индекс) значения, которое нужно вывести из этого массива.

Синтаксис функции ВЫБОР()

ВЫБОР(номер_индекса ;значение1;значение2;…), где

  • Номер_индекса — номер выбираемого аргумента-значения. Номер_индекса должен быть числом от 1 до 254. Индекс можно ввести формулой или ссылкой на ячейку, содержащую число в диапазоне от 1 до 254;
  • Если номер_индекса равен 1, то функция ВЫБОР() возвращает значение1; если он равен 2, возвращается значение2 и так далее;
  • Если номер_индекса меньше 1 или больше, чем номер последнего значения в списке, то функция ВЫБОР возвращает значение ошибки #ЗНАЧ!
  • Если номер_индекса представляет собой дробь, то он усекается до меньшего целого;
  • сами значения значение1;значение2; … могут быть числами, текстовыми строками и ссылками на диапазоны ячеек. Если в качестве значений введены конкретные значения, то функция возвращает одно из этих значений в зависимости от индекса, а если в качестве значений введены ссылки на ячейки, то функция возвращает соответственно ссылки.

Примеры

В диапазоне А8:А12 содержатся школьные оценки от 1 до 5. Необходимо вывести оценку прописью, т.е. «кол»;»неуд»;»удовлетворительно»;»хорошо»;»отлично».

Формула =ВЫБОР(A8;»кол»;»неуд»;»удовлетворительно»;»хорошо»;»отлично») решает эту задачу по выбору значений из списка в Excel. Альтернативное решение можно построить на основе формулы

=ИНДЕКС({«кол»:»неуд»:»удовлетворительно»:»хорошо»:»отлично»};A8)

Данный подход можно использовать для отображения дня недели прописью

=ВЫБОР(A8;»понедельник»;»вторник»;»среда»;»четверг»;»ПЯТНИЦА!!!»;»СУББОТА!!»;»ВОСКРЕСЕНЬЕ!») В этом случае значение в ячейке А8 может принимать значение от 1 до 7.

или времени года. Формула =ВЫБОР(2;»зима»;»весна»;»лето»;»осень») вернет весна.

Можно воспользоваться этой функцией для склонения слов, например, слова Час: 0 часов, 1 час, 2 часа, …

=»час»&ВЫБОР(A17+1;»ов»;»»;»а»;»а»;»а»;»ов»)

Ссылочная форма

Функция ВЫБОР() может возвращать ссылку на диапазон ячеек. Рассмотрим пример суммирования итогов продаж, для заданного пользователем квартала. Пусть имеется таблица продаж по кварталам.

В ячейку А33 пользователь вводит номер квартала (индекс для функции ВЫБОР()). В качестве аргументов указаны 4 диапазона для каждого квартала. При выбор первого квартала будет подсчитана сумма продаж из диапазона А27:А29, при выборе второго — B27:B29 и т.д.

В файле примера также имеются другие примеры, например, подсчет первых 2-х, 3-х и т.д. значений.

Источник

Поделиться:
Нет комментариев

Добавить комментарий

Ваш e-mail не будет опубликован. Все поля обязательны для заполнения.

×
Вам будет интересно